[GitHub] zeppelin pull request #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin pull request #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
GitHub user agura opened a pull request:

    https://github.com/apache/zeppelin/pull/2445

    ZEPPELIN-2674 Ignite version upgraded up to 2.0

    ### What is this PR for?
    Apache Ignite 2.0 brings many improvements and new SQL related functionality. This PR upgrades Ignite version for Ignite interpreter.
   
    ### What type of PR is it?
    [Improvement]
   
    ### What is the Jira issue?
    https://issues.apache.org/jira/browse/ZEPPELIN-2674
   
    ### How should this be tested?
    Unit-tests are enough.


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/agura/incubator-zeppelin zeppelin-2674

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/zeppelin/pull/2445.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2445
   
----

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
Github user 1ambda commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    Hi, could you setup CI?
   
    - http://zeppelin.apache.org/contribution/contributions.html#continuous-integration
    - the forked repository name must be `zeppelin`



---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user 1ambda commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    @agura If you have a problem to set up CI, we can discuss here. Please leave comments.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    @1ambda I'll try a little bit later.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    @1ambda Hi! I still don't have time for set up CI on my laptop. But my changes are so small and related with Ignite interpreter only. All Ignite interpreter tests are passed. Could you please merge this PR?
   
    Thanks for comment about fork name. I'll create new fork for future PRs.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user 1ambda commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    @agura Hi, you don't need to setup CI on your laptop.
   
    1. Signup travis-ci.org
    2. Change your repository incubator-zeppelin to `zeppelin`: https://github.com/agura?tab=repositories
    3. Configure forked repository `zeppelin`in travis CI
    4. Close and reopen this PR.
   
    it takes 5-10 mins.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin pull request #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura closed the pull request at:

    https://github.com/apache/zeppelin/pull/2445


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin pull request #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
GitHub user agura reopened a pull request:

    https://github.com/apache/zeppelin/pull/2445

    ZEPPELIN-2674 Ignite version upgraded up to 2.0

    ### What is this PR for?
    Apache Ignite 2.0 brings many improvements and new SQL related functionality. This PR upgrades Ignite version for Ignite interpreter.
   
    ### What type of PR is it?
    [Improvement]
   
    ### What is the Jira issue?
    https://issues.apache.org/jira/browse/ZEPPELIN-2674
   
    ### How should this be tested?
    Unit-tests are enough.


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/agura/zeppelin zeppelin-2674

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/zeppelin/pull/2445.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2445
   
----
commit af35b4d87b23773184fb11226d01c6bc8c8ccdfa
Author: agura <[hidden email]>
Date:   2017-06-27T13:45:27Z

    ZEPPELIN-2674 Ignite version upgraded up to 2.0

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin pull request #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura closed the pull request at:

    https://github.com/apache/zeppelin/pull/2445


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin pull request #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
GitHub user agura reopened a pull request:

    https://github.com/apache/zeppelin/pull/2445

    ZEPPELIN-2674 Ignite version upgraded up to 2.0

    ### What is this PR for?
    Apache Ignite 2.0 brings many improvements and new SQL related functionality. This PR upgrades Ignite version for Ignite interpreter.
   
    ### What type of PR is it?
    [Improvement]
   
    ### What is the Jira issue?
    https://issues.apache.org/jira/browse/ZEPPELIN-2674
   
    ### How should this be tested?
    Unit-tests are enough.


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/agura/zeppelin zeppelin-2674

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/zeppelin/pull/2445.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2445
   
----
commit af35b4d87b23773184fb11226d01c6bc8c8ccdfa
Author: agura <[hidden email]>
Date:   2017-06-27T13:45:27Z

    ZEPPELIN-2674 Ignite version upgraded up to 2.0

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user 1ambda commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    Hi @agura I guess you didn't setup travis CI for the forked repository.
   
    - https://builds.apache.org/job/zeppelin-pull-request/2647/console
   
    ![image](https://user-images.githubusercontent.com/4968473/29282045-4c0d6db8-815c-11e7-8966-becc501ecb60.png)



---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    @1ambda I didn't update commit. I've updated the commit and check failed with other problem.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    Hi, @1ambda. How should I handle this situation on CI servers?
   
    ```
    The following packages have unmet dependencies:
   
     r-base-dev : Depends: r-base-core (>= 3.2.5-1precise0) but it is not going to be installed
   
    E: Unable to correct problems, you have held broken packages.
   
    apt-get.diagnostics
   
    apt-get install failed
   
    $ cat ~/apt-get-update.log
   
    Ign:1 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2 InRelease
   
    Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease
   
    Hit:4 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2 Release
   
    Ign:5 http://cran.rstudio.com/bin/linux/ubuntu precise/ InRelease
   
    Get:6 http://cran.rstudio.com/bin/linux/ubuntu precise/ Release [3,074 B]
   
    Ign:3 http://toolbelt.heroku.com/ubuntu ./ InRelease
   
    Get:7 http://cran.rstudio.com/bin/linux/ubuntu precise/ Release.gpg [473 B]
   
    Hit:8 http://dl.google.com/linux/chrome/deb stable Release
   
    Hit:9 http://toolbelt.heroku.com/ubuntu ./ Release
   
    Hit:11 http://dl.hhvm.com/ubuntu trusty InRelease
   
    Hit:12 http://ppa.launchpad.net/chris-lea/redis-server/ubuntu trusty InRelease
   
    Ign:13 http://archive.ubuntu.com/ubuntu trusty InRelease
   
    Hit:14 http://apt.postgresql.org/pub/repos/apt trusty-pgdg InRelease
   
    Hit:15 http://archive.ubuntu.com/ubuntu trusty-updates InRelease
   
    Hit:16 http://ppa.launchpad.net/george-edison55/cmake-3.x/ubuntu trusty InRelease
   
    Get:18 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2/multiverse i386 Packages [29 B]
   
    Hit:19 http://archive.ubuntu.com/ubuntu trusty-security InRelease
   
    Ign:20 http://ppa.launchpad.net/couchdb/stable/ubuntu trusty InRelease
   
    Get:10 http://dl.bintray.com/apache/cassandra 39x InRelease [3,168 B]
   
    Hit:21 http://archive.ubuntu.com/ubuntu trusty Release
   
    Hit:22 http://ppa.launchpad.net/git-core/ppa/ubuntu trusty InRelease
   
    Hit:23 http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty InRelease
   
    Get:24 http://cran.rstudio.com/bin/linux/ubuntu precise/ Packages [300 kB]
   
    Hit:25 http://ppa.launchpad.net/pollinate/ppa/ubuntu trusty InRelease
   
    Hit:26 http://ppa.launchpad.net/webupd8team/java/ubuntu trusty InRelease
   
    Hit:27 http://ppa.launchpad.net/couchdb/stable/ubuntu trusty Release
   
    Hit:30 https://packagecloud.io/basho/riak/ubuntu trusty InRelease
   
    Get:31 http://dl.hhvm.com/ubuntu trusty/main i386 Packages [20 B]
   
    Hit:32 https://packagecloud.io/computology/apt-backport/ubuntu trusty InRelease
   
    Hit:33 https://packagecloud.io/github/git-lfs/ubuntu trusty InRelease
   
    Get:34 http://ppa.launchpad.net/chris-lea/redis-server/ubuntu trusty/main i386 Packages [1,716 B]
   
    Hit:35 https://packagecloud.io/rabbitmq/rabbitmq-server/ubuntu trusty InRelease
   
    Get:36 http://apt.postgresql.org/pub/repos/apt trusty-pgdg/main i386 Packages [120 kB]
   
    Get:37 http://archive.ubuntu.com/ubuntu trusty-updates/main i386 Packages [1,197 kB]
   
    Get:38 http://ppa.launchpad.net/george-edison55/cmake-3.x/ubuntu trusty/main i386 Packages [1,611 B]
   
    Get:39 http://archive.ubuntu.com/ubuntu trusty-updates/restricted i386 Packages [20.9 kB]
   
    Get:40 http://archive.ubuntu.com/ubuntu trusty-updates/multiverse i386 Packages [16.1 kB]
   
    Get:41 http://archive.ubuntu.com/ubuntu trusty-updates/universe i386 Packages [545 kB]
   
    Get:42 http://archive.ubuntu.com/ubuntu trusty-security/main i386 Packages [750 kB]
   
    Get:43 http://archive.ubuntu.com/ubuntu trusty-security/restricted i386 Packages [17.6 kB]
   
    Get:44 http://archive.ubuntu.com/ubuntu trusty-security/multiverse i386 Packages [4,183 B]
   
    Get:45 http://archive.ubuntu.com/ubuntu trusty-security/universe i386 Packages [231 kB]
   
    Get:46 http://dl.bintray.com/apache/cassandra 39x/main i386 Packages [682 B]
   
    Get:48 http://archive.ubuntu.com/ubuntu trusty/main i386 Packages [1,739 kB]
   
    Get:49 http://archive.ubuntu.com/ubuntu trusty/restricted i386 Packages [16.4 kB]
   
    Get:50 http://archive.ubuntu.com/ubuntu trusty/multiverse i386 Packages [172 kB]
   
    Get:51 http://archive.ubuntu.com/ubuntu trusty/universe i386 Packages [7,597 kB]
   
    Get:52 http://ppa.launchpad.net/git-core/ppa/ubuntu trusty/main i386 Packages [3,464 B]
   
    Get:53 http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty/main i386 Packages [4,392 B]
   
    Get:54 http://ppa.launchpad.net/pollinate/ppa/ubuntu trusty/main i386 Packages [445 B]
   
    Get:55 http://ppa.launchpad.net/webupd8team/java/ubuntu trusty/main i386 Packages [3,145 B]
   
    Get:57 http://ppa.launchpad.net/couchdb/stable/ubuntu trusty/main i386 Packages [985 B]
   
    Fetched 12.7 MB in 5s (2,157 kB/s)
   
    Reading package lists...
   
    W: http://dl.hhvm.com/ubuntu/dists/trusty/InRelease: Signature by key 36AEF64D0207E7EEE352D4875A16E7281BE7A449 uses weak digest algorithm (SHA1)
   
    W: http://ppa.launchpad.net/couchdb/stable/ubuntu/dists/trusty/Release.gpg: Signature by key 15866BAFD9BCC4F3C1E0DFC7D69548E1C17EAB57 uses weak digest algorithm (SHA1)
   
    The command "sudo -E apt-get -yq --no-install-suggests --no-install-recommends --force-yes install r-base-dev" failed and exited with 100 during .
   
    Your build has been stopped.
    ```


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user 1ambda commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    Hi, what is your base branch? Could you rebase using current master?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    @1ambda Hi! All checks are passed after rebase. Thanks for help. Could you please merge this PR?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user 1ambda commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    LGTM, merge if no more discussion.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[GitHub] zeppelin issue #2445: ZEPPELIN-2674 Ignite version upgraded up to 2.0

asfgit
In reply to this post by asfgit
Github user agura commented on the issue:

    https://github.com/apache/zeppelin/pull/2445
 
    Should I change JIRA ticket status to Resolved or something else in in order to get this PR merged?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---
Loading...